Zero-Day Advisory

Fortinet Discovers WordPress WooCommerce Cross-Site Scripting Vulnerability

Summary

Fortinet's FortiGuard Labs has discovered a stored Cross-Site Scripting (XSS) vulnerability in Automattic WordPress WooCommerce Plugin.


WooCommerce is the world's favorite eCommerce solution that gives both store owners and developers complete control.


A stored XSS vulnerability has been discovered in WooCommerce 3.5.4 and earlier versions. It is caused by inadequate filtering on the image caption.

Solutions

FortiGuard Labs released the following FortiGate IPS signature which covers this specific vulnerability:

WooCommerce.Photoswipe.Caption.XSS
Released Feb 21, 2019

Users should apply the solution provided by Automattic.

Timeline

Fortinet reported the vulnerability to Automattic on Feb 13, 2019.

Automattic confirmed the vulnerability on Feb 18, 2019.

Automattic patched the vulnerability on Feb 20, 2019.

Acknowledgement

This vulnerability was discovered by Zhouyuan Yang of Fortinet's FortiGuard Labs.

IPS Subscription

Fortinet customers who subscribe to Fortinet's intrusion prevention (IPS) service should be protected against this vulnerability with the appropriate configuration parameters in place. Fortinet's IPS service is one component of FortiGuard Subscription Services, which also offer comprehensive solutions such as antivirus, Web content filtering and antispam capabilities. These services enable protection against threats on both application and network layers. FortiGuard Services are continuously updated by FortiGuard Labs, which enables Fortinet to deliver a combination of multi-layered security intelligence and true zero-day protection from new and emerging threats. These updates are delivered to all FortiGate, FortiMail and FortiClient products. Fortinet strictly follows responsible disclosure guidelines to ensure optimum protection during a threat's lifecycle.