PSIRT Advisory

Cross-Site-Scripting (XSS) vulnerabilty in Fortiweb reports

Summary

The URL part of the report message is not encoded in Fortinet FortiWeb which may allow an attacker to execute unauthorized code or commands (Cross Site Scripting) via attack reports generated in HTML format.

Impact

Execute unauthorized code or commands

Affected Products

FortiWeb 6.0.2 and below

Solutions

Upgrade to FortiWeb 6.0.3 or above
Upgrade to FortiWeb 6.1.1 or above

Acknowledgement

Fortinet is pleased to thank Miquel Tur of KPMG Asesores, S.L. for reporting this vulnerability under responsible disclosure.