PSIRT Advisory

FortiSwitch multiple XSS vulnerabilities in the jQuery library

Summary

FortiSwitch is vulnerable to multiple Cross-site Scripting (XSS) attacks present in the jQuery javascript library


CVE-2015-9251:

jQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks when a cross-domain Ajax request is performed without the dataType option, causing text/javascript responses to be executed.


CVE-2012-6708:

jQuery before 1.9.0 is vulnerable to Cross-site Scripting (XSS) attacks. The jQuery(strInput) function does not differentiate selectors from HTML in a reliable fashion. In vulnerable versions, jQuery determined whether the input was HTML by looking for the '

Impact

Cross-site Scripting (XSS)

Affected Products

CVE-2015-9251

FortiSwitch 6.0.0 to 6.0.1, 3.6.8 and below.


CVE-2012-6708

FortiSwitch 3.6.8 and below.

Solutions

Upgrade to 6.0.2 or 3.6.9