Intrusion Prevention

WebkitGTK.Plus.JS.Method.getImageData.Buffere.Overflow

Description

This indicates an attack attempt against a Buffer Overflow Vulnerability in WebkitGTK+.
The vulnerability is due to insufficient sanitizing of user supplied inputs in the application. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application.

Affected Products

WebKitGTK+ version 2.20.3 and prior
WPE WebKit version 2.20.1 and prior

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://bugs.webkit.org/show_bug.cgi?id=186384

CVE References

CVE-2018-12293

Other References

232618 186384 45205