Intrusion Prevention

Apache.Solr.Config.API.Insecure.Deserialization

Description

This indicates an attack attempt to exploit an Insecure Deserialization Vulnerability in Apache Software Foundation Solr
A remote, unauthenticated attacker can exploit this vulnerability by sending a crafted HTTP request to the Config API. Successful exploitation could result in arbitrary code execution in the context of the server application.

Affected Products

Apache Software Foundation Solr 5.0.0 to 5.5.5
Apache Software Foundation Solr 6.0.0 to 6.6.5

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor:
https://issues.apache.org/jira/browse/SOLR-13301

CVE References

CVE-2019-0192