Intrusion Prevention

WooCommerce.Photoswipe.Caption.XSS

Description

This indicates an attack attempt against a Cross-Site Scripting (XSS) vulnerability in Automattic WooCommerce.
The vulnerability is caused by inadequate filtering in the image caption. It allows users with contributor or higher permission to change image caption by uploading a crafted image file to insert arbitrary HTML/Javascript into WooCommerce pages. A remote attacker may be able to exploit this to execute arbitrary script code within the context of the application.

Affected Products

WooCommerce 3.5.4 and earlier versions

Impact

System Compromise : Remote attackers can execute arbitrary script code within the context of the target user's browser

Recommended Actions

Upgrade to the latest version, available from the website.
https://woocommerce.wordpress.com/2019/02/20/woocommerce-3-5-5-security-fix-release/

CVE References

CVE-2019-9168