Intrusion Prevention

Apt-Get.MITM.Redirect.Remote.Code.Injection

Description

This indicates an attack attempt to exploit a Remote Code Injection vulnerability in Advance Package Tool(APT) in Linux.
The vulnerability is due to insufficient sanitizing of user supplied inputs in the application when handling a crafted HTTP redirect. A remote attacker may be able to exploit this to injection malicious content in to a targeted system.

Affected Products

APT versions 1.4.8 and earlier

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Refer to the your operation system's advisory for updates:
https://www.debian.org/security/2019/dsa-4371

CVE References

CVE-2019-3462