Intrusion Prevention

Jenkins.ConfigFileProvider.Comment.XSS

Description

This indicates an attack attempt against a Cross-Site Scripting vulnerability in Jenkins Config File Provider Plugin.
The vulnerability is due to insufficient sanitizing of user-supplied inputs in the application. A remote attacker may be able to exploit this to execute arbitrary script code within the context of the application.

Affected Products

Jenkins Config File Provider Plugin 2.18

Impact

System Compromise: Remote attackers can execute arbitrary script code in the context of the affected system.

Recommended Actions

Refer to the vendor's advisory for updates:
https://jenkins.io/security/advisory/2018-09-25/