Intrusion Prevention

Ghostscript.Failed.Restore.Command.Execution

Description

This indicates an attack attempt to exploit a Command Injection vulnerability in Ghostscript.
The vulnerability is due to insufficient validation when handling a crafted PS File. A remote attacker may be able to exploit this to execute arbitrary OS commands within the context of the application, via a crafted PS File.

Affected Products

Ghostscript 9.23

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Currently we are unaware of any vendor supplied patch or updates available for this issue.

CVE References

CVE-2018-16509