Intrusion Prevention

Samba.libsmbclient.smbc_readdir_internal.Memory.Corruption

Description

This indicates an attack attempt to exploit a Memory Corruption Vulnerability in Samba libsmbclient library.
The vulnerability is due to an error in the vulnerable application when handling a maliciously crafted request. A remote attacker may be able to exploit this to execute arbitrary codes or cause a denial of service condition on the affected system.

Affected Products

Samba 3.2.0 - 4.8.3 (inclusive)

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor:
https://www.samba.org/samba/security/CVE-2018-10858.html

CVE References

CVE-2018-10858