Intrusion Prevention

GitLab.Arbitrary.File.Write

Description

This indicates an attack attempt to exploit an Arbitrary File Write Vulnerability in GitLab GitLab Community Edition (CE) and Enterprise Edition (EE).
The vulnerability is due to an error in the vulnerable application when handling a maliciously crafted Gzip archive. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted Gzip archive.

Affected Products

GitLab GitLab Community Edition (CE) and Enterprise Edition (EE) 10.7.x prior to 10.7.7
GitLab GitLab Community Edition (CE) and Enterprise Edition (EE) 10.8.x prior to 10.8.6
GitLab GitLab Community Edition (CE) and Enterprise Edition (EE) 11.0.x prior to 11.0.4

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor:
https://about.gitlab.com/2018/07/17/critical-security-release-gitlab-11-dot-0-dot-4-released/

CVE References

CVE-2018-14364