Intrusion Prevention

Netgear.NightHawk.PPTP.XSS

Description

This indicates an attack attempt to exploit a Stored Cross-Site Scripting (XSS) vulnerability in Netgear Routers.
The vulnerability is due to insufficient sanitizing of user supplied inputs in the application's point-to-point protocol setting page. A remote attacker may be able to exploit this to execute arbitrary script code.

Affected Products

D3600, running firmware versions prior to 1.0.0.75
D6000, running firmware versions prior to 1.0.0.75
D7800, running firmware versions prior to 1.0.1.44
DM200, running firmware versions prior to 1.0.0.58
R7800, running firmware versions prior to 1.0.2.58
R8900, running firmware versions prior to 1.0.4.12
R9000, running firmware versions prior to 1.0.4.12
RBK20, running firmware versions prior to 2.3.0.28
RBR20, running firmware versions prior to 2.3.0.28
RBS20, running firmware versions prior to 2.3.0.28
RBK40, running firmware versions prior to 2.3.0.28
RBS40, running firmware versions prior to 2.3.0.28
RBK50, running firmware versions prior to 2.3.0.32
RBR50, running firmware versions prior to 2.3.0.32
RBS50, running firmware versions prior to 2.3.0.32
WN3000RPv2, running firmware versions prior to 1.0.0.68
WN3000RPv3, running firmware versions prior to 1.0.2.70
WN3100RPv2, running firmware versions prior to 1.0.0.60
WNDR4300v2, running firmware versions prior to 1.0.0.58
WNDR4500v3, running firmware versions prior to 1.0.0.58
WNR2000v5, running firmware versions prior to 1.0.0.68

Impact

System Compromise: Remote attackers can execute arbitrary script code within the context of the target user's browser