Intrusion Prevention

OMRON.CX-One.Cdmapi32.Buffer.Overflow

Description

This indicates an attack attempt to exploit a Buffer Overflow vulnerability in Omron CX-One.
The vulnerability is caused by an error in the application when handling malformed FLN files. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted FLN file.

Affected Products

CX-One Versions 4.42 and prior
CX-FLnet versions 1.00 and prior
CX-Protocol versions 1.992 and prior
CX-Programmer versions 9.65 and prior
CX-Server versions 5.0.22 and prior
Network Configurator versions 3.63 and prior
Switch Box Utility versions 1.68 and prior

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Upgrade to the latest version, available from the web site.
https://industrial.omron.us/en/products/downloads

CVE References

CVE-2018-8834

Other References

ICSA-18-100-02