Intrusion Prevention

Spring.Framework.spring-messaging.Module.Code.Execution

Description

This indicates an attack attempt to exploit a Remote Code Execution Vulnerability in Pivotal Spring Framework.
The vulnerability is due to an error in the vulnerable application when handling a maliciously crafted request. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted request.

Affected Products

Pivotal Spring Framework 4.3 to 4.3.14
Pivotal Spring Framework 5.0 to 5.0.4
Pivotal Spring Framework prior to 4.x

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor:
https://pivotal.io/security/cve-2018-1270

CVE References

CVE-2018-1270