Intrusion Prevention

Adobe.Flash.Primetime.SDK.Object.Type.Confusion

Description

This indicates an attack attempt to exploit a Type Confusion vulnerability in Adobe Flash Player.
The vulnerability is due to an error when the vulnerable software handles a maliciously crafted SWF file. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted SWF file.

Affected Products

Adobe Flash Player Desktop Runtime 28.0.0.161 and earlier versions on Windows, Macintosh
Adobe Flash Player for Google Chrome 28.0.0.161 and earlier versions on Windows, Macintosh, Linux and Chrome OS
Adobe Flash Player for Microsoft Edge and Internet Explorer 11 28.0.0.161 and earlier versions on Windows 10 and 8.1
Adobe Flash Player Desktop Runtime 28.0.0.161 and earlier versions on Linux

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://helpx.adobe.com/security/products/flash-player/apsb18-05.html

CVE References

CVE-2018-4920

Other References

APSB18-05