Intrusion Prevention

Netgear.DGN2200.UPNP.Buffer.Overflow

Description

This indicates an attack attempt to exploit Stack-Based Buffer Overflow vulnerability in Netgear routers.
The vulnerability is due to an improper boundary check condition in the application. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted request.

Affected Products

DGN2200, running firmware versions prior to 1.0.0.58
DGN2200B, running firmware versions prior to 1.0.0.58
D8500, running firmware versions prior to 1.0.3.42
D7000v2, running firmware versions prior to 1.0.0.51
D6400, running firmware versions prior to 1.0.0.80
D6220, running firmware versions prior to 1.0.0.44
EX7000, running firmware versions prior to 1.0.0.66
EX6200, running firmware versions prior to 1.0.3.88
EX6150, running firmware versions prior to 1.0.0.42
EX7500, running firmware versions prior to 1.0.0.46
JNDR3000, running firmware versions prior to 1.0.0.24
R8000, running firmware versions prior to 1.0.4.18
R8500, running firmware versions prior to 1.0.2.122
R8300, running firmware versions prior to 1.0.2.122
R7900P, running firmware versions prior to 1.4.0.10
R8000P, running firmware versions prior to 1.4.0.10
R7900, running firmware versions prior to 1.0.2.16
R7000P, running firmware versions prior to 1.3.1.44
R7300DST, running firmware versions prior to 1.0.0.68
R7100LG, running firmware versions prior to 1.0.0.46
R6900P, running firmware versions prior to 1.3.1.44
R7000, running firmware versions prior to 1.0.9.32
R6900, running firmware versions prior to 1.0.1.46
R6700, running firmware versions prior to 1.0.1.46
R6400v2, running firmware versions prior to 1.0.2.56
R6400, running firmware versions prior to 1.0.1.42
R6300v2, running firmware versions prior to 1.0.4.28
R6250, running firmware versions prior to 1.0.4.26
WNDR4500v2, running firmware versions prior to 1.0.0.72
WNR3500Lv2, running firmware versions prior to 1.2.0.54

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.