Intrusion Prevention

Apache.Solr.xmlparser.Remote.Code.Injection

Description

This indicates an attack attempt to exploit a remote Code Injection vulnerability in Apache Solar.
The vulnerability is due to insufficient handling of user supplied inputs in the application when handling crafted HTTP requests. A remote attacker can exploit this to execute arbitrary code within the context of the application, via a crafted HTTP request.

Affected Products

Apache Software Foundation Solr 6.x up to 6.6.1
Apache Software Foundation Solr 7.x up to 7.0.1

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Refer to the vendor's advisory for updates:
https://marc.info/?l=apache-announce&m=150786685013286

CVE References

CVE-2017-12629