Intrusion Prevention

Dnsmasq.DNS.Answer.Auth.Request.Integer.Underflow.DoS

Description

This indicates an attack attempt to exploit a Denial of Service vulnerability in Dnsmasq.
The vulnerability is due to an input validation error when handling malformed requests. A remote attacker may be able to exploit this to cause a denial of service condition on the affected system.

Affected Products

DNSmasq/Mikrotik DNSmasq 2.77

Impact

Denial of Service: Remote attackers can crash vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
http://thekelleys.org.uk/gitweb/?p=dnsmasq.git;a=commit;h=63437ffbb58837b214b4b92cb1c54bc5f3279928

CVE References

CVE-2017-13704