Intrusion Prevention

Digium.Asterisk.app.minivm.Caller.ID.Command.Execution

Description

This indicates an attack attempt against a Code Execution vulnerability in Digium Asterisk.
The vulnerability is due to an error when the vulnerable software handles a maliciously crafted SIP request. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted SIP request.

Affected Products

Digium Asterisk Open Source prior to 13.17.1
Digium Asterisk Open Source prior to 14.6.1
Digium Asterisk Open Source prior to 11.25.2
Digium Certified Asterisk prior to 11.6-cert17
Digium Certified Asterisk prior to 13.13-cert5

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Upgrade to the latest version available from the website.
https://downloads.asterisk.org/pub/security/AST-2017-006.html

CVE References

CVE-2017-14100