Intrusion Prevention

Apple.macOS.HelpViewer.X.Help.Script.XSS

Description

This indicates an attack attempt to exploit a Cross Site Scripting vulnerability in Apple MacOS.
The vulnerability is due to an error when the vulnerable software attempts to handle a maliciously crafted request. An attacker can exploit this by tricking a user into viewing the data and execute arbitrary script code within the context of the application.

Affected Products

Apple MacOS 10.12.2 and previous versions.

Impact

System Compromise: Remote attackers can execute arbitrary script code within the context of the target user

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://support.apple.com/HT207483

CVE References

CVE-2017-2361