Intrusion Prevention

OpenSSL.DHE.ECDHE.Parameters.NULL.Pointer.Dereference

Description

This indicates an attack attempt against a NULL pointer Dereference Vulnerability in OpenSSL.
The vulnerability is caused by an error when the vulnerable application handles maliciously crafted DHE and ECDHE parameters. A remote attacker may be able to exploit this to cause a denial of service condition or execute arbitrary code on affected systems.

Affected Products

OpenSSL Project OpenSSL 1.1.x prior to 1.1.0d

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
http://www.openssl.org/news/secadv/20170126.txt

CVE References

CVE-2017-3730