Intrusion Prevention

MS.Windows.Uniscribe.TTF.File.Remote.Code.Execution

Description

This indicates an attack attempt to exploit a Remote Code Execution vulnerability in Microsoft Windows.
The vulnerability is due to an error when the vulnerable software handles a maliciously crafted truetype font file. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted truetype font file.

Affected Products

Windows 7 for 32-bit Systems Service Pack 1 (4010095)
Windows 7 for 32-bit Systems Service Pack 1 (4010098)
Windows 7 for x64-based Systems Service Pack 1 (4010095)
Windows 7 for x64-based Systems Service Pack 1 (4010098)
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (4010095)
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (4010098)
Windows Server 2008 R2 for Itanium-based Systems Service Pack 1 (4010095)
Windows Server 2008 R2 for Itanium-based Systems Service Pack 1 (4010098)
Windows 8.1 for 32-bit Systems (4010096)
Windows 8.1 for 32-bit Systems (4010099)
Windows 8.1 for x64-based Systems (4010096)
Windows 8.1 for x64-based Systems (4010099)
Windows Server 2012 (4010097)
Windows Server 2012 (4010100)
Windows Server 2012 R2 (4010096)
Windows Server 2012 R2 (4010099)
Windows RT 8.1[2] (4010099)
Windows 10 for 32-bit Systems (4009982)
Windows 10 for x64-based Systems (4009982)
Windows 10 Version 1511 for 32-bit Systems (4009983)
Windows 10 Version 1511 for x64-based Systems (4009983)
Windows 10 Version 1607 for 32-bit Systems (3217574)
Windows 10 Version 1607 for x64-based Systems (3217574)
Windows Server 2016 for x64-based Systems (3217574)
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation) (4010095)
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation) (4010098)
Windows Server 2012 (Server Core installation) (4010097)
Windows Server 2012 (Server Core installation) (4010100)
Windows Server 2012 R2 (Server Core installation) (4010096)
Windows Server 2012 R2 (Server Core installation) (4010099)
Windows Server 2016 for x64-based Systems (Server Core installation) (3217574)

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
http://technet.microsoft.com/security/bulletin/MS17-013

CVE References

CVE-2017-0014