Intrusion Prevention

Adobe.Flash.DisplayList.Handling.Buffer.Overflow

Description

This indicates an attack attempt to exploit a Code Execution vulnerability in Adobe Flash Player.
The vulnerability is due to an error when the vulnerable software handles a maliciously crafted SWF file. A remote attacker may be able to exploit this to execute arbitrary code on vulnerable systems, via a crafted SWF file.

Affected Products

Adobe Flash Player Desktop Runtime 18.0.0.232 and earlier Windows and Macintosh
Adobe Flash Player Extended Support Release 18.0.0.232 and earlier Windows and Macintosh
Adobe Flash Player for Google Chrome 18.0.0.233 and earlier Windows, Macintosh, Linux and ChromeOS
Adobe Flash Player for Microsoft Edge and Internet Explorer 11 18.0.0.232 and earlier Windows 10
Adobe Flash Player for Internet Explorer 10 and 11 18.0.0.232 and earlier Windows 8.0 and 8.1
Adobe Flash Player for Linux 11.2.202.508 and earlier Linux
AIR Desktop Runtime 18.0.0.199 and earlier Windows and Macintosh
AIR SDK 18.0.0.199 and earlier Windows, Macintosh, Android and iOS
AIR SDK & Compiler 18.0.0.180 and earlier Windows, Macintosh, Android and iOS
AIR for Android 18.0.0.143 and earlier Android

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://helpx.adobe.com/security/products/flash-player/apsb15-23.html

CVE References

CVE-2015-5587