Intrusion Prevention

Adobe.Flash.Player.SharedObject.Destructor.Type.Confusion

Description

This indicates an attack attempt to exploit a Type Confusion vulnerability in Adobe Flash Player.
The vulnerability is due to an error when the vulnerable software handles a maliciously crafted SWF file. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted SWF file.

Affected Products

Adobe Flash Player Desktop Runtime 18.0.0.194 and earlier on Windows and Macintosh
Adobe Flash Player Extended Support Release 13.0.0.296 and earlier on Windows and Macintosh
Adobe Flash Player for Google Chrome 18.0.0.194 and earlier on Windows, Macintosh and Linux
Adobe Flash Player for Internet Explorer 10 and Internet Explorer 11 18.0.0.194 and earlier on Windows 8.0 and 8.1
Adobe Flash Player 11.2.202.468 and earlier on Linux
AIR Desktop Runtime 18.0.0.144 and earlier on Windows and Macintosh
AIR SDK 18.0.0.144 and earlier on Windows, Macintosh, Android and iOS
AIR SDK & Compiler 18.0.0.144 and earlier on Windows, Macintosh, Android and iOS

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://helpx.adobe.com/security/products/flash-player/apsb15-16.html

CVE References

CVE-2015-3122