Intrusion Prevention

Tuleap.PHP.Unserialize.Code.Execution

Description

This indicates an attack attempt to exploit a Code Injection Vulnerability in Tuleap.
The vulnerability is due to an input validation error while parsing a crafted HTTP request. A remote attacker could exploit this to execute arbitrary code within the context of the application, via a crafted HTTP request.

Affected Products

Tuleap version 7.6 or prior

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
https://tuleap.net/plugins/tracker/?aid=7601

CVE References

CVE-2014-8791