Intrusion Prevention

NetBSD.tnftp.fetch.fetch_url.Command.Execution

Description

This indicates an attack attempt to exploit a Code Injection Vulnerability in NetBSD tnftp.
The vulnerability is due to an input validation error while parsing a crafted HTTP response. A remote attacker could exploit this to execute arbitrary code within the context of the application, via a crafted HTTP response.

Affected Products

NetBSD Foundation tnftp prior to tnftp-20141031

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
http://seclists.org/oss-sec/2014/q4/459

CVE References

CVE-2014-8517