Intrusion Prevention

Adobe.Flash.Player.RMTP.Memory.Corruption

Description

This indicates an attack attempt to exploit a Memory Corruption vulnerability in Adobe Flash Player.
The vulnerability is due to an error when the vulnerable software handles a maliciously crafted RTMP message. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted RTMP message.

Affected Products

Adobe Flash Player 14.0.0.179 and earlier versions
Adobe Flash Player 13.0.0.241 and earlier 13.x versions
Adobe Flash Player 11.2.202.400 and earlier versions for Linux
Adobe AIR desktop runtime 14.0.0.178 and earlier versions
Adobe AIR SDK 14.0.0.178 and earlier versions
Adobe AIR SDK & Compiler 14.0.0.178 and earlier versions
Adobe AIR 14.0.0.179 and earlier versions for Android

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
http://helpx.adobe.com/security/products/flash-player/apsb14-21.html

CVE References

CVE-2014-0549