Intrusion Prevention

CUPS.Filter.Bash.Environment.Variable.Code.Injection

Description

This indicates an attack attempt to exploit a Code Injection Vulnerability in CUPS filters for CUPS print server.
The vulnerability is due to an input validation error while parsing a crafted HTTP request. A remote attacker could exploit this to execute arbitrary code within the context of the application, via a crafted HTTP request.

Affected Products

CUPS version 1.4.3 on Ubuntu 10.04 (x86)
CUPS version 1.5.3 on Debian 7 (x64)
CUPS version 1.6.2 on Fedora 19 (x64)
CUPS version 1.7.2 on Ubuntu 14.04 (x64)

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Currently we are unaware of any vendor supplied patch for this issue.

CVE References

CVE-2014-6278 CVE-2014-6271