Intrusion Prevention

Adobe.Flash.JPEG.zlib.Compression.Memory.Leakage

Description

This indicates an attack attempt to exploit a Memory Leakage vulnerability in Adobe Flash Player.
The vulnerability is due to an error when the vulnerable software handles a maliciously crafted JPEG file. An attacker can exploit this by tricking an unsuspecting user into visiting a malicious webpage, and bypass ASLR protection mechanism on the targeted user's system to perform other attacks.

Affected Products

Flash Player Active X plugin for Internet Explorer 14.0.0.145 and earlier versions
Flash Player Windows NPAPI plugin for Firefox 14.0.0.145 and earlier versions
Flash Player 14.0.0.145 and earlier versions (network distribution)
Flash Player 11.2.202.394 and earlier for Linux
Flash Player 14.0.0.145 and earlier for Chrome (Windows, Macintosh and Linux)
Flash Player 14.0.0.145 and earlier in Internet Explorer 10 for Windows 8.0
Flash Player 14.0.0.145 and earlier in Internet Explorer 11 for Windows 8.1
AIR 14.0.0.110 and earlier versions
AIR 14.0.0.137 SDK & Compiler and earlier versions
AIR 14.0.0.137 SDK and earlier versions
AIR 14.0.0.137 and earlier versions for Android

Impact

Security Bypass: Remote attackers can bypass security checks of vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
http://helpx.adobe.com/security/products/flash-player/apsb14-18.html

CVE References

CVE-2014-0544