Intrusion Prevention

OpenSSL.Incorrect.ChangeCipherSpec.Injection

Description

This indicates an attack attempt against an Information Disclosure vulnerability in OpenSSL.
The vulnerability is due to insufficient input validation in the application when handling a crafted SSL Change Cipher Spec message. A man-in-middle attacker can exploit this to decrypt and read the ssl traffic from a vulnerable server by injecting crafted SSL requests.

Affected Products

OpenSSL 0.9.8
OpenSSL 1.0.0
OpenSSL 1.0.1

Impact

Information Disclosure: Remote attackers can gain sensitive information from vulnerable systems.

Recommended Actions

Apply the most recent upgrade or patch from the vendor.
http://www.openssl.org/news/secadv_20140605.txt

CVE References

CVE-2014-0224