Intrusion Prevention

PhpMyAdmin.Preg.Replace.Remote.Code.Execution

Description

This indicates an attack attempt against a remote Code Execution vulnerability in phpMyAdmin.
The vulnerability is caused by an error when the vulnerable software handles a malicious HTTP request containing a crafted URI. A remote attacker may be able to exploit this to execute arbitrary code within the context of the application, via a crafted HTTP request.

Affected Products

phpMyAdmin versions 3.5.x before 3.5.8.1
phpMyAdmin versions 4.0.0 before 4.0.0-rc3
PHP versions after 5.4.6 are not vulnerable.

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Upgrade to the latest version available from the website.
http://www.phpmyadmin.net

CVE References

CVE-2013-3238