Intrusion Prevention

Apple.Safari.libxslt.XSL.Handling.Memory.Corruption

Description

This indicates an attack attempt to exploit a memory corruption vulnerability in Safari.
The vulnerability is due to insufficient sanitization in Apple Safari's libxml2 when handling XML file. An attacker can exploit this by tricking an unsuspecting user into visiting a malicious webpage and execute arbitrary code within the context of the application.

Affected Products

iPhone 4
iPhone 5
iPod touch (5th generation)
iPad 2
iPad 3
iPad 4

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply patch, available from the website.
http://support.apple.com/kb/HT5934

CVE References

CVE-2012-2871