Intrusion Prevention

EMC.AlphaStor.Device.Manager.Buffer.Overflow

Description

This indicates an attack attempt against a Buffer Overflow vulnerability in EMC AlphaStor Device Manager (DCP).
The vulnerability is caused by an error due to insufficient boundary checks during creation of a device name. A remote attacker may be able exploit this to execute arbitrary code within the context of the application or possibly cause a denial of service condition.

Affected Products

EMC AlphaStor 4.0 prior to build 814

Impact

System Compromise: Remote attackers can execute arbitrary code within the context of the affected service.

Recommended Actions

A patch fixing this vulnerability is available for Registered EMC Powerlink customers on the Powerlink portal.

CVE References

CVE-2013-0930

Other References

1028056