Intrusion Prevention

Apple.QuickTime.Plugin.SetLanguage.Buffer.Overflow

Description

This indicates an attack attempt to exploit a Buffer Overflow vulnerability in Apple QuickTime Plugin.
The vulnerability, which is located in the "QTPlugin.ocx" ActiveX control, can be exploited through misuse of the "SetLanguage" method. It may allow remote attackers to execute arbitrary code in the context of the application, using the affected ActiveX control.

Affected Products

QuickTime prior to 7.7.2

Impact

System Compromise: Remote attackers can execute arbitrary script code within the context of the target user's browser

Recommended Actions

Apply the most recent upgrade or patch from the vendor
http://support.apple.com/kb/HT5261

CVE References

CVE-2012-0666