Intrusion Prevention

MS.NET.Framework.Class.Inheritance.Code.Execution

Description

This indicates an attack attempt against a Code Execution vulnerability in Microsoft .NET Framework and Silverlight framework.
The vulnerability is caused by an error when the vulnerable software handles a malicious ".net" file. It allows a remote attacker to execute arbitrary code via sending a crafted Silverlight application.

Affected Products

Microsoft .NET Framework 1.0 Service Pack 3 on Windows XP Tablet Edition 2005 Service Pack 3 and Windows XP Media Center Edition 2005 Service Pack 3
Microsoft .NET Framework 1.1 Service Pack 1
Microsoft .NET Framework 1.1 Service Pack 1 when installed on Windows XP Service Pack 3
Microsoft .NET Framework 1.1 Service Pack 1 when installed on Windows XP Professional x64 Edition Service Pack 2
Microsoft .NET Framework 1.1 Service Pack 1 on Windows Server 2003 Service Pack 2
Microsoft .NET Framework 1.1 Service Pack 1 when installed on Windows Server 2003 x64 Edition Service Pack 2
Microsoft .NET Framework 1.1 Service Pack 1 when installed on Windows Server 2003 Itanium-based Edition Service Pack 2
Microsoft .NET Framework 1.1 Service Pack 1 when installed on Windows Vista Service Pack 2
Microsoft .NET Framework 1.1 Service Pack 1 when installed on Windows Vista x64 Edition Service Pack 2
Microsoft .NET Framework 1.1 Service Pack 1 when installed on Windows Server 2008 for 32-bit Systems Service Pack 2*
Microsoft .NET Framework 1.1 Service Pack 1 when installed on Windows Server 2008 for x64-based Systems Service Pack 2*
Microsoft .NET Framework 1.1 Service Pack 1 when installed on Windows Server 2008 for Itanium-based Systems Service Pack 2
Microsoft .NET Framework 2.0 Service Pack 2
Microsoft .NET Framework 2.0 Service Pack 2 when installed on Windows XP Service Pack 3
Microsoft .NET Framework 2.0 Service Pack 2 when installed on Windows XP Professional x64 Edition Service Pack 2
Microsoft .NET Framework 2.0 Service Pack 2 when installed on Windows Server 2003 Service Pack 2
Microsoft .NET Framework 2.0 Service Pack 2 when installed on Windows Server 2003 x64 Edition Service Pack 2
Microsoft .NET Framework 2.0 Service Pack 2 when installed on Windows Server 2003 with SP2 for Itanium-based Systems
Microsoft .NET Framework 2.0 Service Pack 2 on Windows Vista Service Pack 2
Microsoft .NET Framework 2.0 Service Pack 2 on Windows Vista x64 Edition Service Pack 2
Microsoft .NET Framework 2.0 Service Pack 2 on Windows Server 2008 for 32-bit Systems Service Pack 2*
Microsoft .NET Framework 2.0 Service Pack 2 on Windows Server 2008 for x64-based Systems Service Pack 2*
Microsoft .NET Framework 2.0 Service Pack 2 on Windows Server 2008 for Itanium-based Systems Service Pack 2
Microsoft .NET Framework 3.5.1
Microsoft .NET Framework 3.5.1 on Windows 7 for 32-bit Systems and Windows 7 for 32-bit Systems Service Pack 1
Microsoft .NET Framework 3.5.1 on Windows 7 for x64-based Systems and Windows 7 for x64-based Systems Service Pack 1
Microsoft .NET Framework 3.5.1 on Windows Server 2008 R2 for x64-based Systems and Windows Server 2008 R2 for x64-based Systems Service Pack 1*
Microsoft .NET Framework 3.5.1 on Windows Server 2008 R2 for Itanium-based Systems and Windows Server 2008 R2 for Itanium-based Systems Service Pack 1
Microsoft .NET Framework 4
Microsoft .NET Framework 4 when installed on Windows XP Service Pack 3[1]
Microsoft .NET Framework 4 when installed on Windows XP Professional x64 Edition Service Pack 2[1]
Microsoft .NET Framework 4 when installed on Windows Server 2003 Service Pack 2[1]
Microsoft .NET Framework 4 when installed on Windows Server 2003 x64 Edition Service Pack 2[1]
Microsoft .NET Framework 4 when installed on Windows Server 2003 with SP2 for Itanium-based Systems[1]
Microsoft .NET Framework 4 when installed on Windows Vista Service Pack 2[1]
Microsoft .NET Framework 4 when installed on Windows Vista x64 Edition Service Pack 2[1]
Microsoft .NET Framework 4 when installed on Windows Server 2008 for 32-bit Systems Service Pack 2**[1]
Microsoft .NET Framework 4 when installed on Windows Server 2008 for x64-based Systems Service Pack 2**[1]
Microsoft .NET Framework 4 when installed on Windows Server 2008 for Itanium-based Systems Service Pack 2[1]
Microsoft .NET Framework 4 when installed on Windows 7 for 32-bit Systems and Windows 7 for 32-bit Systems Service Pack 1[1]
Microsoft .NET Framework 4 when installed on Windows 7 for x64-based Systems and Windows 7 for x64-based Systems Service Pack 1[1]
Microsoft .NET Framework 4 when installed on Windows Server 2008 R2 for x64-based Systems and Windows Server 2008 R2 for x64-based Systems Service Pack 1**[1]
Microsoft .NET Framework 4 when installed on Windows Server 2008 R2 for Itanium-based Systems and Windows Server 2008 R2 for Itanium-based Systems Service Pack 1[1]
Microsoft Silverlight 4
Microsoft Silverlight 4 when installed on Mac
Microsoft Silverlight 4 when installed on all releases of Microsoft Windows clients
Microsoft Silverlight 4 when installed on all releases of Microsoft Windows servers

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Refer to the vendor's web site for the suggested workaround:
http://www.microsoft.com/technet/security/Bulletin/ms11-078.mspx

CVE References

CVE-2011-1253