Intrusion Prevention

Check.Point.VPN1.ISAKMP.Buffer.Overflow

Description

This indicates an attack attempt to exploit a Buffer Overflow vulnerability in Check Point VPN-1 Server.
The vulnerability is caused by an error in the vulnerable system when handling a large "Certificate Request" packet. It may allow remote attackers to execute arbitrary code by sending a crafted "Certificate Request" packet.

Affected Products

Check Point Software Technologies VPN-1 4.1 (Gold through SP6).
Check Point Software Technologies VPN-1 SecureRemote/SecureClient NG With Application Intelligence v4.1 (Prior to Build 4200)

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Currently we are not aware of any vendor supplied patch for this issue.

CVE References

CVE-2004-0040