Intrusion Prevention

MS.IE.Vector.Markup.Language.Remote.Code.Execution

Description

This indicates an attack attempt against a remote Code Execution vulnerability in Microsoft Internet Explorer.
The vulnerability is caused by an error when the vulnerable software handles a specially crafted web page. It allows a remote attacker to execute arbitrary code.

Affected Products

Internet Explorer 6 for Windows XP Service Pack 3
Internet Explorer 6 for Windows XP Professional x64 Edition Service Pack 2
Internet Explorer 6 for Windows Server 2003 Service Pack 2
Internet Explorer 6 for Windows Server 2003 x64 Edition Service Pack 2
Internet Explorer 6 for Windows Server 2003 with SP2 for Itanium-based Systems
Internet Explorer 7 for Windows XP Service Pack 3 Remote Code Execution
Internet Explorer 7 for Windows XP Professional x64 Edition Service Pack 2 Remote Code Execution
Internet Explorer 7 for Windows Server 2003 Service Pack 2
Internet Explorer 7 for Windows Server 2003 x64 Edition Service Pack 2
Internet Explorer 7 for Windows Server 2003 with SP2 for Itanium-based Systems
Internet Explorer 7 in Windows Vista Service Pack 1 and Windows Vista Service Pack 2 Remote Code Execution
Internet Explorer 7 in Windows Vista x64 Edition Service Pack 1 and Windows Vista x64 Edition Service Pack 2 Remote Code Execution
Internet Explorer 7 in Windows Server 2008 for 32-bit Systems and Windows Server 2008 for 32-bit Systems Service Pack 2
Internet Explorer 7 in Windows Server 2008 for x64-based Systems and Windows Server 2008 for x64-based Systems Service Pack 2
Internet Explorer 7 in Windows Server 2008 for Itanium-based Systems and Windows Server 2008 for Itanium-based Systems Service Pack 2
Internet Explorer 8 for Windows XP Service Pack 3
Internet Explorer 8 for Windows XP Professional x64 Edition Service Pack 2
Internet Explorer 8 for Windows Server 2003 Service Pack 2
Internet Explorer 8 for Windows Server 2003 x64 Edition Service Pack 2
Internet Explorer 8 in Vista Service Pack 1 and Windows Vista Service Pack 2
Internet Explorer 8 in Windows Vista x64 Edition Service Pack 1 and Windows Vista x64 Edition Service Pack 2
Internet Explorer 8 in Windows Server 2008 for 32-bit Systems and Windows Server 2008 for 32-bit Systems Service Pack 2
Internet Explorer 8 in Windows Server 2008 for x64-based Systems and Windows Server 2008 for x64-based Systems Service Pack 2
Internet Explorer 8 in Windows 7 for 32-bit Systems and Windows 7 for 32-bit Systems Service Pack 1
Internet Explorer 8 in Windows 7 for x64-based Systems and Windows 7 for x64-based Systems Service Pack 1
Internet Explorer 8 in Windows Server 2008 R2 for x64-based Systems and Windows Server 2008 R2 for x64-based Systems Service Pack 1
Internet Explorer 8 in Windows Server 2008 R2 for Itanium-based Systems and Windows Server 2008 R2 for Itanium-based Systems Service Pack 1

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the patch, available from the vendor's web site:
http://www.microsoft.com/technet/security/Bulletin/MS11-052.mspx

CVE References

CVE-2011-1266