Intrusion Prevention

Adobe.Flash.Player.AS3.addEventListener.Memory.Corruption

Description

This indicates a possible attack against a memory corruption vulnerability in Adobe Flash Player.
This vulnerability is due to an error when the vulnerable software handles a malformed Flash file. An attacker may exploit this to execute arbitrary code.

Affected Products

Adobe Flash Player 10.2.159.1 and earlier versions for Windows, Macintosh,
Linux and Solaris operating systems.
Adobe Flash Player 10.2.154.28 and earlier versions for Chrome.
Adobe Flash Player 10.2.157.51 and earlier versions for Android.

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Apply the patch supplied by the vendor:
http://www.adobe.com/support/security/bulletins/apsb11-12.html

CVE References

CVE-2011-0622