Intrusion Prevention

Iconics.Genesis.WebHMI.ActiveX.Stack.Overflow

Description

This indicates an attack attempt to exploit a Stack Overflow vulnerability in Iconics Genesis 32.
The vulnerability, which is located in the "GenVersion.dll" ActiveX control, can be exploited through mis-use of the "SetActiveXGUID" property. It may allow remote attackers to execute arbitrary code in the context of the application using the affected ActiveX control. Failed exploit attempts will likely cause the program to crash, resulting in a Denial of Service condition.

Affected Products

Iconics Genesis 32 version 9.21

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Currently we are unaware of any vendor supplied patch for this issue.

CVE References

CVE-2011-2089