Intrusion Prevention

DotNetNuke.Padding.Oracle.Attack

Description

This indicates a padding oracle attack against DotNetNuke, an open source platform for building web sites based on ASP.net.
The vulnerability is caused by a design error when the vulnerable software handles multiple HTTP requests for a web resource. It allows a remote attacker to bypass security checking of vlunerable systems.

Affected Products

DotNetNuke based on Microsoft .NET Framework 4.0 and prior versions

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.
Information Disclosure: Remote attackers can gain sensitive information from vulnerable systems.

Recommended Actions

Refer to the following web site for the suggested workaround:
http://www.microsoft.com/technet/security/advisory/2416728.mspx

CVE References

CVE-2010-3332