Intrusion Prevention

Multiple.Media.Player.M3U.File.Handling.Buffer.Overflow

Description

This indicates an attack attempt against a buffer-overflow vulnerability in VUPlayer.
The vulnerability is caused by an error when the vulnerable software handles a specially crafted .m3u file. It allows a remote attacker to execute arbitrary code via sending a crafted .m3u file.

Affected Products

VUPlayer 2.44

Impact

System Compromise: Remote attackers can gain control of vulnerable systems.

Recommended Actions

Upgrade to non-vulnerable versions.

CVE References

CVE-2009-3429 CVE-2006-6251