Intrusion Prevention

Alt-N.Technologies.Security.Gateway.Username.Buffer.Overflow

Description

This indicates an attack attempt against a buffer-overflow vulnerability in Alt-N Technologies SecurityGateway.
The vulnerability is caused by a boundary error in the processing of malformed HTTP requests. This may be exploited to execute arbitrary code.

Affected Products

Alt-N SecurityGateway 1.0.1

Impact

System Compromise

Recommended Actions

Update to version 1.0.2:
http://www.altn.com/Downloads/.

CVE References

CVE-2008-4193