Intrusion Prevention

TikiWiki.Tiki.Graph.Formula.PHP.Code.Injection

Description

This indicates an attempt to exploit a PHP code injection vulnerability in TikiWiki.
The vulnerability is caused by failure to check user input in "tiki-graph_formula.php". It allows remote attackers to execute arbitrary PHP code via the "f" array parameter.

Affected Products

TikiWiki Project, TikiWiki 1.9.8

Impact

System Compromise: remote attackers can gain control of vulnerable systems.

Recommended Actions

Update to version 1.9.8.2,available from the website:
http://sourceforge.net/project/showfiles.php?group_id=64258

CVE References

CVE-2007-5423