Intrusion Prevention

Adobe.Photoshop.Products.PNG.File.Buffer.Overflow

Description

This indicates an attempt to exploit a buffer-overflow vulnerability common to Adobe Photoshop and Adobe Photoshop Elements.
The vulnerability is caused by the software's inability to properly handle specially crafted ".PNG" file. A remote attacker may exploit this to execute arbitrary code on a vulnerable system.

Affected Products

Adobe Photoshop CS2
Adobe Photoshop CS3
Adobe Photoshop Elements version 5.0 and prior

Impact

System compromise: Remote code execution.

Recommended Actions

Currently we are not aware of any officially supplied fix for this issue.

CVE References

CVE-2007-2366 CVE-2007-2365