Intrusion Prevention

Ipswitch.Collaboration.Suite.IMail.Code.Execution

Description

This indicates a possible exploit of a buffer overflow vulnerability in Ipswitch Collaboration Suite and IMail.
This issue is due to buffer overflow errors that occur in the "IMAILAPILib.IMailServer", "IMAILAPILib.IMailLDAPService" and "IMAILAPILib.IMailUserCollection" ActiveX controls when processing malformed arguments.

Affected Products

Ipswitch IMail Premium 2006
Ipswitch IMail Plus 2006
Ipswitch IMail 2006
Ipswitch Collaboration Suite Standard 2006

Impact

The execution of arbitrary code on the system.

Recommended Actions

Upgrade to version 2006.2:
http://www.ipswitch.com/downloads/index.asp

CVE References

CVE-2007-1637