Intrusion Prevention

Omni.NFS.Server.NFSD.EXE.Stack.Buffer.Overflow

Description

A vulnerability has been identified in XLink Omni-NFS, which could be exploited by remote attackers to take complete control of an affected system. This flaw is due to a buffer overflow error in the NFS server that does not properly handle malformed requests, which could be exploited by remote attackers to execute arbitrary commands by sending specially crafted packets to a vulnerable system.

Affected Products

XLink Omni-NFS version 4.2 and prior.
XLink Omni-NFS Enterprise version 5.2 and prior.

Impact

Execute arbitrary code.

Recommended Actions

Currently we are not aware of any solutions for this issue.
http://www.xlink.com/product_link.htm.

CVE References

CVE-2006-5780