Intrusion Prevention

RunCMS.NewBBPlus.SQL.Injection

Description

Multiple SQL injection vulnerabilities in RunCMS 1.2 and earlier allow remote attackers to execute arbitrary SQL commands via the (1) addquery and (2) subquery parameters to the newbb plus module, the forum parameter to (3) newtopic.php, (4) edit.php, or (5) reply.php in the newbb plus module, or (6) the msg_id parameter to print.php in the messages module.

Affected Products

RunCMS RunCMS 1.2
RunCMS RunCMS 1.1 A
RunCMS RunCMS 1.1

Impact

Manipulation of data

Recommended Actions

The vulnerabilities were reportedly silently patched in mid July.

CVE References

CVE-2005-2692