Endpoint Vulnerability

Microsoft: Dynamics On-Premise Elevation of Privilege Vulnerability

Description

An elevation of privilege vulnerability exists in Dynamics On-Premise v9. An attacker who successfully exploited the vulnerability could leverage a customizer privilege within Dynamics to gain control of the Web Role hosting the Dynamics installation. To exploit this vulnerability, an attacker needs to have credentials for a user that has permission to author customized business rules in Dynamics, and persist XAML script in a way that causes it to be interpreted as code. The update addresses the vulnerability by restricting XAML activities to a whitelisted set.

Affected Products

Microsoft Dynamics 365 (on-premises) version 9.0

References

CVE-2019-1229,