Endpoint Vulnerability

Microsoft SQL Server Remote Code Execution Vulnerability

Description

A remote code execution vulnerability exists in Microsoft SQL Server when it incorrectly handles processing of internal functions. An attacker who successfully exploited this vulnerability could execute code in the context of the SQL Server Database Engine service account. To exploit the vulnerability, an authenticated attacker would need to submit a specially crafted query to an affected SQL server. The security update addresses the vulnerability by modifying how the Microsoft SQL Server Database Engine handles the processing of functions.

Affected Products

Microsoft SQL Server 2014 Service Pack 3 for 32-bit Systems (GDR),Microsoft SQL Server 2014 Service Pack 3 for 32-bit Systems (CU+GDR),Microsoft SQL Server 2014 Service Pack 2 for x64-based Systems (GDR),Microsoft SQL Server 2014 Service Pack 2 for 32-bit Systems (GDR),Microsoft SQL Server 2016 for x64-based Systems Service Pack 1 (CU+GDR),Microsoft SQL Server 2016 for x64-based Systems Service Pack 2 (CU+GDR),Microsoft SQL Server 2014 Service Pack 2 for 32-bit Systems (CU+GDR),Microsoft SQL Server 2016 for x64-based Systems Service Pack 1 (GDR),Microsoft SQL Server 2014 Service Pack 3 for x64-based Systems (GDR),Microsoft SQL Server 2017 for x64-based Systems (GDR)

References

CVE-2019-1068,